$re = '~(/)(\d+)(/?)~m';
$str = '/users/12345 becomes /users/XXXXX
/users/234567/summary becomes /users/XXXXXX/summary
/api/v1/summary/5678 becomes /api/v1/summary/XXXX
http://example.com/api/v1/summary/5678/single becomes http://example.com/api/v1/summary/XXXX/single
';
$subst = "$1XYZ$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;