$re = '/INTERFACE\(([^(),\s]*),\s*([^(),\s]+),\s*([^,()\s]+)[^()]*\)/m';
$str = 'INTERFACE(A, B, C, D) and INTERFACE(A, B, C).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);