re = /INTERFACE\(([^(),\s]*),\s*([^(),\s]+),\s*([^,()\s]+)[^()]*\)/m
str = 'INTERFACE(A, B, C, D) and INTERFACE(A, B, C).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end