$re = '/^playstation\.com$/m';
$str = 'playstation.com
playstation4com.org
smetrics.aem.playstation.com
telemetry-console.api.playstation.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);