re = /^playstation\.com$/m
str = 'playstation.com
playstation4com.org
smetrics.aem.playstation.com
telemetry-console.api.playstation.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end