$re = '/B(?<=^...|^..|^.|^)|B(?=.{0,3}$)/m';
$str = 'AAAABBBBAAAA
ABAABBBBAAAA
AAAABBBBABAA
BAAABBBBAAAB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);