re = /B(?<=^...|^..|^.|^)|B(?=.{0,3}$)/m
str = 'AAAABBBBAAAA
ABAABBBBAAAA
AAAABBBBABAA
BAAABBBBAAAB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end