$re = '/foo\([^\)]*\K(?:\')([^\'\)]*)(?:\'\))/m';
$str = 'foo(\'Alice\')
foo(\'Alice\', \'Bob\', \'Charlie\')
foo(flag ? \'Alice\' : \'Bob\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);