re = /foo\([^\)]*\K(?:')([^'\)]*)(?:'\))/m
str = 'foo(\'Alice\')
foo(\'Alice\', \'Bob\', \'Charlie\')
foo(flag ? \'Alice\' : \'Bob\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end