package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[\w.-][\w\+.-]*@[\w.-]+\.[a-z]{2,4}$`)
var str = `santo+abc@gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}