$re = '/^[\w.-][\w\+.-]*@[\w.-]+\.[a-z]{2,4}$/i';
$str = 'santo+abc@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);