package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+([-]{1})?)+[.]jpg`)
var str = `test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--test.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}