$re = '/(\w+([-]{1})?)+[.]jpg/m';
$str = 'test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--test.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);