import re
regex = re.compile(r"^(?>(?:\"\"[^\"\"\n]*\"\"|[^;\"\"\n]+)*)\"\"?[^\"\";\n]*(;.*)", flags=re.MULTILINE)
test_str = ("Peekaboo ; A comment starts with a semicolon and continues until the EOL\n"
"...unless the semicolon is surrounded by unescaped dquotes \"Don’t do it ; here\" ;but match me; once\n"
"Im not surrounded \"so pay attention to me\" ; \"peekaboo\"\n"
"Im not surrounded \"so pay attention\" to;me\" ; \"peekaboo\"\n"
"Im not surrounded \"so pay attention to me ; peekaboo\n"
"Dquote escapes a dquote so \"dont pay attention to \"\"me;here\"\" buster\" do it ; here\n"
"Don’t pay attention to \"\"\"me;here\"\"\" but do \"\"it;here\"\"\n"
"and \"dont do \"\"it;here\"\"\" either ;peekaboo\n"
"but \"pay attention to \"it;here\"\" ;not here though\n"
"Simon said \"I like goats\" then he added \"and sheep;\" ;a good comment is \"here\n"
"Simon said \"I like goats\" then he added \"and sheep;\" dont do it here\n"
"Simon said \"\"I like goats;\"peekaboo\n"
"Simon said \"I like goats;\"\"peekaboo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")