$re = '/^(?:\W+|(\w)(?=.*(\1\W*(?(2)\2)$)))*\w?\2?$/i';
$str = 'A man, a plan, a canal; Panama.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);