re = /^(?:\W+|(\w)(?=.*(\1\W*(?(2)\2)$)))*\w?\2?$/i
str = 'A man, a plan, a canal; Panama.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end