$re = '/(:3:Start)(.*?)(:31:Start.*:31:End)?(.*)(:3:End)/';
$str = ':3:Start!@#$%^&*():31:Start!@#$%^&*():31:End!@#$%^&*():3:End
:3:Start!@#$%^&*()!@#$%^&*():3:End';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);