// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(:3:Start)(.*?)(:31:Start.*:31:End)?(.*)(:3:End)").unwrap();
let string = ":3:Start!@#$%^&*():31:Start!@#$%^&*():31:End!@#$%^&*():3:End
:3:Start!@#$%^&*()!@#$%^&*():3:End";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}