package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`;(\d+,[a-zA-Z]+);`)
var str = `;;abc,123;,,;456,def;789,ghi,135,jkl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}