$re = '/;(\d+,[a-zA-Z]+);/';
$str = ';;abc,123;,,;456,def;789,ghi,135,jkl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);