$re = '/(?<your_field>.*)_\d/m';
$str = ' a_b_c_9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);