import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\W\\d_]+\\.?(?:[- ][^\\W\\d_]+\\.?)*$";
final String string = "Valid street names are:\n"
+ "Mainstreet.\n"
+ "Mainstreet\n"
+ "Main Street\n"
+ "Big New mainstreet\n"
+ "Mainstreet-New\n"
+ "Mains Str.\n"
+ "St. Alexander Street\n"
+ "abcÜüßäÄöÖàâäèéêëîï ôœùûüÿçÀÂ-ÄÈÉÊËÎÏÔŒÙÛÜŸÇ.\n"
+ "John Kennedy Street\n\n"
+ "Not valid street names are:\n"
+ "Mainstreet #+;:_*´`?=)(/&%$§!\n"
+ "Mainstreet#+;:_*´`?=)(/&%$§!\n"
+ "Mainstreet 2\n"
+ "Mainstreet..\n"
+ "Mainstreet§\n\n"
+ "Valid cities are:\n"
+ "Edinôœùûüÿ\n"
+ "Berlin.\n"
+ "St. Petersburg\n"
+ "New-Berlin\n"
+ "Aue-Bad Schlema\n"
+ "Frankfurt am Main\n"
+ "Nürnberg\n"
+ "Ab\n"
+ "New York CityßäÄöÖàâäèéêëîïôœùûüÿçÀÂ-ÄÈÉÊËÎÏÔŒÙÛÜŸ\n"
+ "Not valid cities are:\n\n"
+ "Edingburgh 123\n"
+ "Edingburg123\n"
+ "St. Andrews 12\n"
+ "Berlin,#+;:_*´`?=)(/&%$§!\n"
+ "Berlin__\n"
+ "The solutions that I have at the moment matches very close but not perfectly:\n\n"
+ "For city and street name:\n"
+ "Unfortunately no match for these examples (the rest works fine):\n\n"
+ "St. Alexander Street\n"
+ "St. Petersburg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}