# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\W\d_]+\.?(?:[- ][^\W\d_]+\.?)*$"
test_str = ("Valid street names are:\n"
"Mainstreet.\n"
"Mainstreet\n"
"Main Street\n"
"Big New mainstreet\n"
"Mainstreet-New\n"
"Mains Str.\n"
"St. Alexander Street\n"
"abcÜüßäÄöÖàâäèéêëîï ôœùûüÿçÀÂ-ÄÈÉÊËÎÏÔŒÙÛÜŸÇ.\n"
"John Kennedy Street\n\n"
"Not valid street names are:\n"
"Mainstreet #+;:_*´`?=)(/&%$§!\n"
"Mainstreet#+;:_*´`?=)(/&%$§!\n"
"Mainstreet 2\n"
"Mainstreet..\n"
"Mainstreet§\n\n"
"Valid cities are:\n"
"Edinôœùûüÿ\n"
"Berlin.\n"
"St. Petersburg\n"
"New-Berlin\n"
"Aue-Bad Schlema\n"
"Frankfurt am Main\n"
"Nürnberg\n"
"Ab\n"
"New York CityßäÄöÖàâäèéêëîïôœùûüÿçÀÂ-ÄÈÉÊËÎÏÔŒÙÛÜŸ\n"
"Not valid cities are:\n\n"
"Edingburgh 123\n"
"Edingburg123\n"
"St. Andrews 12\n"
"Berlin,#+;:_*´`?=)(/&%$§!\n"
"Berlin__\n"
"The solutions that I have at the moment matches very close but not perfectly:\n\n"
"For city and street name:\n"
"Unfortunately no match for these examples (the rest works fine):\n\n"
"St. Alexander Street\n"
"St. Petersburg\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.