$re = '/\((?:[^()]+|\g<2>*)\)/';
$str = '(ifаавif(fdfыа))';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;