import Foundation
let pattern = #"\((?:[^()]+|\g<2>*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(ifаавif(fdfыа))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)