import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BEGIN:VEVENT.*?END:VEVENT";
final String string = "BEGIN:VEVENT\n"
+ "DTSTAMP:20220301T023567Z\n"
+ "UID: xxx\n"
+ "DTSTART;TZID=Asia/Tokyo:20210630T110000\n"
+ "DTEND;TZID=Asia/Tokyo:20210630T160000\n"
+ "DESCRIPTION:\\n--------\\n同日入替 : false\\n前回ゲスト数 : 1\\n次\n"
+ "SUMMARY: xxxxx (xxx / xxx xxx\n"
+ "END:VEVENT\n"
+ "BEGIN:VEVENT\n"
+ "DTSTAMP:20221105T072143Z\n"
+ "UID: xxx\n"
+ "DTSTART;TZID=Asia/Tokyo:20210501T110000\n"
+ "DTEND;TZID=Asia/Tokyo:20210701T160000\n"
+ "DESCRIPTION:\\n--------\\n同日入替 : false\\n前回ゲスト数 : 1\\n次\n"
+ "SUMMARY: xxx (xxx / xxx xxx)\n"
+ "END:VEVENT\n"
+ "BEGIN:VEVENT\n"
+ "DTSTAMP:20220905T023143Z\n"
+ "UID: xxx\n"
+ "DTSTART;TZID=Asia/Tokyo:20220227T110000\n"
+ "DTEND;TZID=Asia/Tokyo:20220227T160000\n"
+ "DESCRIPTION:\\n--------\\n同日入替 : true\\n前回ゲスト数 : 2\\n次回\n"
+ "SUMMARY:★ xxx (xxx / xxx xxx)\n"
+ "END:VEVENT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}