re = /([\d\w,"])|(\[\])|({})/m
str = '[1, [], [3, [[4]]]]
[1, {}, [3, [[4]]]]
[[["a"]], [["b"]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end