#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http(?:s|):\/\/(?:www.|)website\.com\/catalog\/(?:trinkets\/.[^\/]+\/|)(\d+)"
Local $sString = "https://www.website.com/catalog/trinkets/item-news-standart-formy/1772/" & @CRLF & _
"https://www.website.com/catalog/trinkets/item/1772/" & @CRLF & _
"https://www.website.com/catalog/1772" & @CRLF & _
"http://www.website.com/catalog/trinkets/item-news-standart-formy/1772/" & @CRLF & _
"http://www.website.com/catalog/trinkets/item/1772/" & @CRLF & _
"http://www.website.com/catalog/1772" & @CRLF & _
"https://website.com/catalog/trinkets/item-news-standart-formy/1772/" & @CRLF & _
"https://website.com/catalog/trinkets/item/1772/" & @CRLF & _
"https://website.com/catalog/1772"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"возвращяются $1 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")