import Foundation
let pattern = #"http(?:s|):\/\/(?:www.|)website\.com\/catalog\/(?:trinkets\/.[^\/]+\/|)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
https://www.website.com/catalog/trinkets/item/1772/
https://www.website.com/catalog/1772
http://www.website.com/catalog/trinkets/item-news-standart-formy/1772/
http://www.website.com/catalog/trinkets/item/1772/
http://www.website.com/catalog/1772
https://website.com/catalog/trinkets/item-news-standart-formy/1772/
https://website.com/catalog/trinkets/item/1772/
https://website.com/catalog/1772"
возвращяются $1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)