package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((0x)?[0-9A-F]+[,\-\s]*)+$`)
var str = `012345678901234567890123456789_0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}