const regex = /^((0x)?[0-9A-F]+[,\-\s]*)+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0x)?[0-9A-F]+[,\\-\\s]*)+$', 'g')
const str = `012345678901234567890123456789_0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}