import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Integrity checksum changed for:\\s\\'(?<pathName>[^\\']+)";
final String string = "2016 Oct 30 19:13:08 (AAV) 145.46.122.14->syscheck-registry\n"
+ " Rule: 596 (level 5) -> 'Registry Integrity Checksum Changed Again (3rd time)'\n"
+ " Integrity checksum changed for: 'HKEY_LOCAL_MACHINE\\Security\\SAM\\Domains\\Account'\n"
+ " Old md5sum was: '27511968a811898f0d7f1fed393d31d7'\n"
+ "5. New md5sum is : '5876c6ae278cce7ff2108d8396e10ddc'\n"
+ " Old sha1sum was: 'd94f9ea544b6b04caabc80d5bbe6b94854ae3406'\n"
+ " New sha1sum is : 'b46d17a3ddc54b5d03464374514398a1835f857e'\n\n\n\n"
+ "2016 Oct 29 06:53:09 (AAB) 145.46.40.146->syscheck-registry\n"
+ " Rule: 594 (level 5) -> 'Registry Integrity Checksum Changed'\n"
+ " Integrity checksum changed for: 'HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Services\\Tomcat'\n"
+ " Old md5sum was: '3288a8f072b45b2fa9d879b2ba0fe453'\n"
+ "5. New md5sum is : 'ff17914ec4722e9b7d3scdb508c5d55d'\n"
+ " Old sha1sum was: '4d6b33e40721s837cd8de090ef0468b6b20a1f3b'\n"
+ " New sha1sum is : '270dca37b8681ca739de4493b704333fb3be86a3'\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}