$re = '/\d{2}\/\d{2}\/20\d{2}/m';
$str = 'app-20.10.2 26/10/2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);