$re = '/(?<![.\d])(?:(?:0*1(?:[.]0+)?)|(?=0+(?:[^\d.]|$))0+|0*[.]\d+)(?![\d.])/m';
$str = '(See Tests)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);