re = /(?<![.\d])(?:(?:0*1(?:[.]0+)?)|(?=0+(?:[^\d.]|$))0+|0*[.]\d+)(?![\d.])/m
str = '(See Tests)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end