#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(cet(a|ă)(t|ț)e(an|nie))\s+((francez(a|ă)?)|(rom(a|â)n(a|â)?)|(austriac(a|â)?)|(german(a|ă)?)|(italian(a|ă)?)|(turc(a|ă)?)|(ceh(a|ă)?)|(belgian(a|ă)?)|(spaniol(a|ă)?)|(ungur(easca|ească)?)|(cipriot|(ciprioat(a|ă)?))|(bulgar(a|ă)?)|(chinez)|moldovean|polonez|sarb|grec|englez|olandez(greac(a|â)?)|(elvetian(a|ă)?)|(vietnamez(a|ă)?)|(rus(a|ă)?)|(ucrainean(a|ă)?)|(polonez(a|ă)?)|(libanez(a|ă)?)|(israelian(a|ă)?)|(indian(a|ă)?)|(sirian(a|ă)?)|(american(a|ă)?)|(canadian(a|ă)?)|(englez(a|ă)?)|(suedez(a|ă)?)|(norvegian(a|ă)?))"
Local $sString = "cetatean român" & @CRLF & _
"cetatenie cipriota" & @CRLF & _
"" & @CRLF & _
"cetatean grec" & @CRLF & _
"cetatenie elvetiana"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")