$re = '/(cet(a|ă)(t|ț)e(an|nie))\s+((francez(a|ă)?)|(rom(a|â)n(a|â)?)|(austriac(a|â)?)|(german(a|ă)?)|(italian(a|ă)?)|(turc(a|ă)?)|(ceh(a|ă)?)|(belgian(a|ă)?)|(spaniol(a|ă)?)|(ungur(easca|ească)?)|(cipriot|(ciprioat(a|ă)?))|(bulgar(a|ă)?)|(chinez)|moldovean|polonez|sarb|grec|englez|olandez(greac(a|â)?)|(elvetian(a|ă)?)|(vietnamez(a|ă)?)|(rus(a|ă)?)|(ucrainean(a|ă)?)|(polonez(a|ă)?)|(libanez(a|ă)?)|(israelian(a|ă)?)|(indian(a|ă)?)|(sirian(a|ă)?)|(american(a|ă)?)|(canadian(a|ă)?)|(englez(a|ă)?)|(suedez(a|ă)?)|(norvegian(a|ă)?))/m';
$str = 'cetatean român
cetatenie cipriota
cetatean grec
cetatenie elvetiana';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);