#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*\.)?(?:microsoft|bing)\.(?:de|com)$"
Local $sString = "something.microsoft.com" & @CRLF & _
"something.bing.de" & @CRLF & _
"somethingmicrosoft.com" & @CRLF & _
"something-bing.com" & @CRLF & _
"microsoft.com" & @CRLF & _
"bing.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")