package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\W_0-9]*([a-zA-Z]+).*`)
var str = ` 0_hello world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}