$re = '/^[\W_0-9]*([a-zA-Z]+).*/m';
$str = ' 0_hello world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);