$re = '/^((?!some|bad|words).)*$/m';
$str = 'This should match
This bad string should not match
hello bad
hello
this is some
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);