re = /^((?!some|bad|words).)*$/m
str = 'This should match
This bad string should not match
hello bad
hello
this is some
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end