package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^/]*$`)
var str = `images/celebs/2017/6/nikolay-drozdov_small.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}