$re = '/[^/]*$/m';
$str = 'images/celebs/2017/6/nikolay-drozdov_small.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);