$re = '/\d+(?=[A-Za-z])/m';
$str = '1This is a test. 42And this is a test for 123 numbers within the text.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);