re = /\d+(?=[A-Za-z])/m
str = '1This is a test. 42And this is a test for 123 numbers within the text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end