using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([\w-]+).*?>(.*?)<\/\1>";
string input = @"<strong id=""bla"">
Much Content <a href=""#"">Test</a>
</strong>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}