$re = '/<([\w-]+).*?>(.*?)<\/\1>/s';
$str = '<strong id="bla">
Much Content <a href="#">Test</a>
</strong>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);