#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\bfox\b)"
Local $sString = "the quick brown fox // matches" & @CRLF & _
"fox jumps over the lazy dog // matches" & @CRLF & _
"quick brown fox jumps over // matches" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"the quick brownfox // does not match" & @CRLF & _
"foxjumps over the lazy dog // does not match" & @CRLF & _
"quick brownfox jumps over // does not match" & @CRLF & _
"quick brown foxjumps over // does not match" & @CRLF & _
"quick brownfoxjumps over // does not match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")