re = /(?m)^(.+?),"(.+?)","([^,]+)",/
str = 'Title,Des,Description,价格,原价,SKU,库存,产品类别,供应商,产品系列,SEO标题,SEO描述
Pendientes Olivia,"El verde es uno de los colores más nobles en la joyería alta, este par de hermosos pendientes con un cristal de color verde esmeralda resalta tu elegancia, imprescindible para poder lucir tus joyas","Pendientes de Plata de Ley 925
Acabado: Baño en Oro de 14k
Alto: 2.6cm
Sistema de cierre: Tuerca tradicional
Peso: 2.1g",14.95,,PE10004AU,100,Pendientes,Vltana,Pendientes,Comprar pendientes Olivia en Vltana,Pendientes Olivia Descubre nuestro modelo de pendientes de plata de diseño y calidad. Consigue la Última Novedad de Vltana. Compra de forma segura y hazte con este Best Seller. Envíos Gratis desde 30€.
Pendientes Bagan,"Un interior de color blanco perlado y un marco irregular dorado, se han creado una combinación inesperada. Su textura suave y fina presenta un estilo clásico y elegante. La sencillez y su naturaleza acaban siendo una pieza irremplazable.","Pendientes de Plata de Ley 925
Acabado: Baño en Oro de 18k
Largo: 1.3cm
Sistema de cierre: Tuerca tradicional
Peso: 0.9g",19.95,,PE10005AU,50,Pendientes,Vltana,Pendientes,Comprar pendientes Bagan en Vltana,Pendientes Bagan Descubre nuestro modelo de pendientes de plata de diseño y calidad. Consigue la Última Novedad de Vltana. Compra de forma segura y hazte con este Best Seller. Envíos Gratis desde 30€.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end